Aller au contenu

-->

WordPress, PHP5 et mon hébergement…

php5 htaccess hébergeurPourquoi ai-je une erreur avec wordpress ? comment activer php5 sur mon site ? erreur wordpress 1&1… pour répondre à toutes ces questions, j’ai compilé un aide mémoire sur une page qui regroupe les divers moyens d’activer php5 selon votre hébergeur.

En effet, une erreur de WordPress, d’un plugin provient bien souvent d’une ancienne version de php.
Selon les hébergeurs (qui ne sont pas encore tous passés à PHP5 !), la méthode pour activer php5 diffère.
La plupart du temps, cela passe par l’édition de son fichier .htaccess.
Dans cet aide mémoire, vous trouverez les lignes à ajouter pour les hébergeurs suivants :

  • 1et1 ou 1and1
  • OVH
  • Free
  • Lycos
  • Nuxit
  • GoDaddy
  • Alwaysdata
  • Amen
  • Infomaniak
  • Produweb
  • NFrance
  • Web1
  • Online.net
  • extend

Voici le pdf : Aide mémoire php5 et htaccess
Vous pouvez le diffuser librement.

Comment savoir sous quelle version de php tourne mon blog ?
Réponse : le plugin phpinfo (gratuit)

Vous connaissez d’autres hébergeurs qui sont en php4 par défaut et ne sont pas listés ici ?
Vite, un commentaire !

Voir également:

  • hébergement wordpress
  • htaccess wordpress 1and1
  • htaccess wordpress online
  • hebergement php5
  • htaccess wordpress online net
  • online net wordpress
  • wordpress online net
  • htaccess online net wordpress
  • htaccess wordpress php5
  • wordpress htaccess online net
 

Le 4 décembre 2010 dans Astuces

Taggé avec , , , , , , , .


12 Réponses

  1. Hervé Royer a dit

    RT @SylvainDeaure: WP: WordPress, PHP5 et mon hébergement… http://j.mp/hvN8kT

  2. emile12 a dit

    RT @SylvainDeaure: WP: WordPress, PHP5 et mon hébergement… http://j.mp/hvN8kT

  3. webwep a dit

    Alors cet article présente le problème que j’ai eu hier en voulant installer le Wp d’un client. Obligé de créer un .htaccess en 444 pour résoudre le problème !

    • Sylvain (admin) a dit

      C’est ça… Il y a encore des hébergeurs qui tournent, par défaut, sous php4.

  4. affiliation a dit

    Oui et nous on a dû perdre de précieuses heures pour comprendre qu’en faite le .htaccess était écrasé lors d’une mise à jour

    • Sylvain (admin) a dit

      Haha !

      En effet, c’est le genre de chose qu’on peut facilement oublier…
      une mise à jour et plus rien ne va…

      Sur le fond, l’idéal est bien évidemment de choisir pour les nouveaux hébergements un prestataire qui propose php5 par défaut.

  5. backoffice a dit

    Merci pour ce doc, certains perdent du temps à aller toujours chercher le bout de code PH5 correspondant à notre hébergeur …

  6. Dennis U Carroll a dit

    WordPress, PHP5 et mon hébergement… http://www.blog-expert.fr/astuces/wordpress-php5-hebergement-644.html

  7. Erz a dit

    Merci pour la solution ! Je suis tombé sur cet article car j’étais confronté à ce problème ! J’avais php4 par défaut … hum je donnerai pas le nom de l’hébergeur…mais c’est pas leur seul problème !

  8. marcp06 a dit

    Merci pour cet article et le pdf bien sûr ;)
    Marc

  9. Eroan a dit

    J’ai perdu environ une heure à rechercher la solution à mon erreur 500…

    Merci pour cet article, j’ai trouvé la solution (code dans le htaccess) en cherchant « wordpress 1and1 htaccess » sur Google ;)

  10. etudier au canada a dit

    WordPress est un excellent script pour les blogs et les blogueurs mais parfois il posent certains problèmes comme celui-là dans cet article, il existe aussi un autre problème dans la nouvelle version avec les liens de la vidéo et l’ajustement de la taille de la vidéo, mais globalement wordpress reste le meilleur pour les blogs.



Un peu d'HTML est OK